Kein Copy-Paste bei Überweisungen?

 
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 19
Dabei seit: 09 / 2011
Betreff:

Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 26.09.2011 - 11:41 Uhr  ·  #1
Hi!

Wenn ich eine Überweisung ausfülle,
kann ich keine Kontodaten aus einer Mail per Copy-Paste einfügen.
strg+v bleibt im Eingabefeld ohne Wirkung.

Zusätzlich nervt noch,
dass während der Eingabe der Bankleitzahl
durch alt+tab von Hibiscus zur Mail und wieder zurück
der Cursor an den Anfang der Eingabe gesetzt wird.
Das passiert nur bei der BLZ, nicht bei Konto oder Verwendungszweck.

Ist das insgesamt ein gewolltes Verhalten?

Gruß
Manfred
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 7769
Dabei seit: 03 / 2005
Betreff:

Re: Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 26.09.2011 - 13:31 Uhr  ·  #2
Zitat geschrieben von obf-manfred
Wenn ich eine Überweisung ausfülle,
kann ich keine Kontodaten aus einer Mail per Copy-Paste einfügen.
strg+v bleibt im Eingabefeld ohne Wirkung.


Das liegt am Zeilenumbruch. Beim Kopieren via <STRG><C> hattest du nicht nur die Zeile markiert sondern auch noch den Zeilenumbruch am Ende dieser Zeile. Da die Eingabefelder fuer Kontonummer und BLZ jedoch als Zeichen nur 0-9 und Leerzeichen zulassen, befand sich in der Zwischenablage ein ungueltiges Zeilenumbruchszeichen - das Einfuegen wurde daher abgebrochen.

Wenn du also nur die Zeichen kopierst - ohne den Zeilenumbruch am Ende - dann sollte das Einfuegen funktionieren.

Mir selbst war dieses Problem nie aufgefallen, da ich beim Kopieren darauf immer geachtet habe. Da ich aber hin und wieder mal eine Mail von Usern kriege, die mir von diesem Problem schrieben (und ich das bisher immer als irgendwelche Windows-spezifischen Bugs abgetan hatte), hab ich das jetzt mal analysiert und das mit dem Zeilenumbruch rausgefunden.

Ist gefixt und ab morgen im Nightly-Build von Jameica. Wird beim Einfuegen von Text via Zwischenablage jetzt festgestellt, dass ein Zeilenumbruch enthalten ist, wird dieser automatisch entfernt, damit der text eingefuegt werden kann.

Zitat geschrieben von obf-manfred
Zusätzlich nervt noch, dass während der Eingabe der Bankleitzahl
durch alt+tab von Hibiscus zur Mail und wieder zurück der Cursor an den Anfang der Eingabe gesetzt wird. Das passiert nur bei der BLZ, nicht bei Konto oder Verwendungszweck.


Das liegt an der "Auto-Korrektur" der BLZ. Gibt man die mit Leerzeichen ein (z.Bsp. so: "123 456 78"), dann werden bei einem Fokus-Wechsel automatisch die Leerzeichen entfernt. Das Ersetzen von Text fuehrt jedoch dazu, dass (zumindest Windows, bei meinem Linux ist mir das nicht passiert) der Cursor an den Anfang des Textes zurueckgesetzt wird. Ich hab das daher jetzt so geaendert, dass die Text-Aktualisierung jetzt nur durchgefuehrt wird, wenn auch wirklich Leerzeichen enthalten waren. Wenn keine enthalten sind, sollte der Cursor jetzt also hinten stehen bleiben. Falls jedoch wirklich welche drin sind, werden sie entfernt. Hierbei wird der Cursor aber weiterhin an den Anfang des Eingabefeldes zurueckgesetzt. Wuerde ich das ebenfalls aendern, wuerde ein zusaetzliches Modify-Event ausgeloest, welches Neben-Effekte haben koennte. Die jetzige Loesung sollte aber in der Regel ihren Dienst tun.

Ist ab morgen im Nightly-Build von Hibiscus.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 19
Dabei seit: 09 / 2011
Betreff:

Re: Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 27.09.2011 - 09:55 Uhr  ·  #3
Zitat geschrieben von hibiscus
Ist ab morgen im Nightly-Build von Hibiscus.


In der Tat. Funktioniert jetzt einwandfrei.

Also mal ehrlich: Wie geil ist das denn?
Da poste ich einen Bug hier im Forum und AM NÄCHSTEN Tag
ist das Ding beseitigt. Hut ab!

Gruß
Manfred
Benutzer
Avatar
Geschlecht:
Beiträge: 321
Dabei seit: 11 / 2003
Betreff:

Re: Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 27.09.2011 - 12:36 Uhr  ·  #4
Der Knüller wäre jetzt natürlich, wenn man aus einer Email o.ä. einen gesamten Text markieren könnte und beim hibiscus Überweisungsformular "aus Zwischenablage einfügen" drücken könnte und hibiscus sucht sich aus der Zischenablage die korrekten Werte heraus.

Code
Empfänger: Max Mustermann
Konto: 12345
BLZ: 12345678
Betrag: 1,00
Verwendungszweck: Bekannt

^^^^Also derartiges aus einer Mail/Text/... kopiert und eingefügt in hibiscus generiert/füllt die Überweisung :roll:
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 7769
Dabei seit: 03 / 2005
Betreff:

Re: Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 27.09.2011 - 12:46 Uhr  ·  #5
Hast du es mal ausprobiert? ;)
Kopiere genau diesen Text 1:1 in die Zwischenablage und erstelle dann eine neue Ueberweisung.
Benutzer
Avatar
Geschlecht:
Beiträge: 321
Dabei seit: 11 / 2003
Betreff:

Re: Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 27.09.2011 - 12:51 Uhr  ·  #6
Tatsache ;)

Ich hatte das letztens mal versucht, da hat es definitiv nicht geklappt.

Welche Konstellationen findet dein Parser? Oder muss die Zwischenablage immer exakt so aussehen wie oben?
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 7769
Dabei seit: 03 / 2005
Betreff:

Re: Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 27.09.2011 - 12:57 Uhr  ·  #7
- Name und Wert muessen auf jeden Fall mit Doppelpunkt getrennt sein.
- Gross-Kleinschreibung spielt keine Rolle
- Als Kontonummer wird erkannt, wenn vor dem Doppelpunkt irgendwas mit "nummer", "konto" oder "kto" steht.
- Die BLZ wird erkannt, wenn "Bankleitzahl" oder "BLZ" da steht
- Verwendungszweck, wenn irgendwas mit "zweck" da steht
- Name des Gegenkonto-Inhabers wird gefunden bei irgendwas mit "Inhaber", "Name", "Empfänger" oder "Empfaenger"
Benutzer
Avatar
Geschlecht:
Beiträge: 321
Dabei seit: 11 / 2003
Betreff:

Re: Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 27.09.2011 - 13:06 Uhr  ·  #8
Perfekt, danke für die Erläuterungen...
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 16
Dabei seit: 02 / 2008
Betreff:

Kaufabwicklung eBay

 · 
Gepostet: 02.05.2012 - 00:10 Uhr  ·  #9
Hallo Olaf,

einfach super wie Du den Leuten hilfst und die Software ständig weiter entwickelst. Großes Lob! Ich benutz' Hibiscus gerne.

Aber nun zum Thema (daher hol ich ja den alten Thread hoch):
Ich kaufe öfters mal bei eBay ein und nutze dann die Überweisung/Kaufabwicklung. Bei der Kaufabwicklung stehen dann die ganzen Daten des Empfängers. Nur funktioniert das Kopieren und automatisches Einfügen beim Anlegen einer Überweisung nicht. Eine kurze Recherche brachte mich auf diesen Thread. Ich wusste doch das dies geht. Daher habe ich einmal die kopierten Daten der Kaufabwicklung in eine Textdatei eingefügt und das Problem vermutlich schon gefunden. Beim Kopieren werden Zeilenumbrüche eingefügt:
Zitat
Empfänger:
<Name_des_Empfängers>
Kontonummer des Empfängers:
<1234567890>
Bankleitzahl:
<12345678>
Name der Bank:
<Testkasse>

Verwenden Sie bei internationalen Überweisungen bitte die folgenden Codes:
IBAN:
<DE123456789...>
BIC (SWIFT):
<NOxxxxxxxxxx>

Verwendungszweck:
<Verwendungszweck/Rechnungsnummer>


Kannst Du hierfür evtl. auch etwas zur Verfügung stellen? Ich denke dieses Feature würden einige nutzen.

Gruß
Alexander
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 7769
Dabei seit: 03 / 2005
Betreff:

Re: Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 03.05.2012 - 23:04 Uhr  ·  #10
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 16
Dabei seit: 02 / 2008
Betreff:

Re: Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 23.05.2012 - 23:59 Uhr  ·  #11
Danke für's einbauen! Heute habe ich mit anfänglichen Problemen den Nightly-Build (Win 32Bit mit Java 6) zum Laufen bekommen und getestet.

Leider funktioniert es bei mir nicht. Muss noch etwas beachtet werden ?

Gruß
Alexander
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 7769
Dabei seit: 03 / 2005
Betreff:

Re: Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 24.05.2012 - 16:22 Uhr  ·  #12
Ich hab das sowohl unter Linux als auch unter Windows getestet. Mit genau dem von dir am 02.05. genannten Aufbau. Bei mir funktionierte das.
Benutzer
Avatar
Geschlecht:
Herkunft: Bremen
Alter: 63
Homepage: heinzboettjer.wor…
Beiträge: 57
Dabei seit: 04 / 2014
Betreff:

Re: Kein Copy-Paste bei Überweisungen?

 · 
Gepostet: 30.09.2014 - 09:32 Uhr  ·  #13
Altes Thema neue Konstellation.

Wenn ich
Code
1m Profi-Verbindungskabel ( 4mm² ) Solarmodul zu Solarladeregler
versuche als Verwendungszweck einzufügen passier nicht. Schuld ist ².

Wäre es möglich das ungültige Zeichen durch einen * oder ähnliches zu ersetzen?

Dann ist Mensch nicht überrascht und zweifelt an sich selbst.
Gewählte Zitate für Mehrfachzitierung:   0