DiBa & Linux: Wie klappt's?

 
Guestuser
 
Avatar
 
Betreff:

Re: DiBa & Linux: Wie klappt's?

 · 
Gepostet: 06.01.2003 - 22:08 Uhr  ·  #1
Hi, ich würde gerne von Linux aus meine Konten bei der <a href='http://www.diba.de/' target='_blank'>DiBa</a> bedienen. Als Webbrowser nutze ich Opera 6.03 und Konqueror 3.0.5. Das Betriebssystem ist SuSE 8.1 (2.4.19).

Mit Opera komme ich sogar bis zum <a href='https://banking.diba.de/' target='_blank'>Anmeldedialog</a> wo man Kontonummer, Identifier und PIN eingeben kann, wenn ich dem Browser so einstelle, das er sich als MSIE5.0 ausgibt. Leider stürzt Opera aber ab, wenn ich die Felder ausgefüllt habe und den Anmelde-Button betätige. Mit dem Konqueror komme ich erst gar nicht so weit, da die DiBa scheinbar den Browsernamen abfragt.

Gibt es trotzdem irgendeinen Weg? Die DiBa hat mir auf Anfrage mitgeteilt, dass man sich unter Linux ja eine Windowsemulation installieren könnte, aus der heraus dann auch der MSIE gestartet werden kann, wobei man für das Funktionieren dieses Weges leider keine Garantien einräumen könne. Mir persönlich ist das zu umständlich, weswegen ich auf einen Tip von Euch hoffe :)
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 7444
Dabei seit: 08 / 2002
Betreff:

Re: DiBa & Linux: Wie klappt's?

 · 
Gepostet: 07.01.2003 - 13:58 Uhr  ·  #2
Hi FSup,

hast du schon den neusten Mozilla/Netscape getestet? Damit würde ich es als erstes ausprobieren.

Kommst du mit Opera eigentlich auch bis zur Anmeldung, wenn du als Fake-Browser auf Netscape einstellst?

Achso: Sind die Cookies aktiviert? Wenn die generell ohne Rückfrage abgewiesen werden, dann kann das auch zu merkwürdigen Probs führen.

Viel Glück beim Testen!



<!--EDIT|Raimund Sichmann|2003-01-7-->
Guestuser
 
Avatar
 
Betreff:

Re: DiBa & Linux: Wie klappt's?

 · 
Gepostet: 07.01.2003 - 14:22 Uhr  ·  #3
Also ich habe es gerade mal mit dem Konqueror ausprobiert. Habe als Browserkennung IE 5.01 angegeben.

Ich habe zwar kein Konto bei der DiBa, aber wenn ich erfundene Zahlen eingebe, bekomme ich nach Anmelden den Hinweis: Legitimation fehlgeschlagen.

Ich denke also mal, dass es prinzipiell funktionieren würde.
Bei der SuSE 8.1 Standardinstallation ist für DSL allerdings die MRU/MTU nicht richtig gesetzt. Dazu einmal in /etc/ppp/peers/pppoe und t-dsl die Werte MTU und MRU=1492 eintragen. Eventuell auch noch in /etc/ppp/options (bin ich mir aber nicht sicher, da ich es dort auch nicht stehen habe)

Bevor ich das alles eingetragen hatte, gingen einige SSL verschlüsselte Seiten nicht. Der Browser lädt eine lange Weile und danach kommt ne Fehlermeldung.

Hoffe das Hilft
Guestuser
 
Avatar
 
Betreff:

Re: DiBa & Linux: Wie klappt's?

 · 
Gepostet: 07.01.2003 - 17:31 Uhr  ·  #4
Zitat geschrieben von Raimund Sichmann
hast du schon den neusten Mozilla/Netscape getestet? Damit würde ich es als erstes ausprobieren.

Kommst du mit Opera eigentlich auch bis zur Anmeldung, wenn du als Fake-Browser auf Netscape einstellst?

Achso: Sind die Cookies aktiviert? Wenn die generell ohne Rückfrage abgewiesen werden, dann kann das auch zu merkwürdigen Probs führen.

Netscape und Mozilla habe ich nicht ausprobiert. Es handelt sich um einen P233MMX mit 256MB - der ist von SuSE8.1 mit KDE3 schon ziemlich am Ende, weswegen ich bei den Anwendungen gerne auf schlanke Lösungen setze.

Ob eine andere Browserkennung erlaubt ist habe ich noch nicht probiert. Aber Sie testen es auf jeden Fall nicht über die Existenz von JavaScriptfunktionen - da gibt es beim MSIE nämlich eine Reihe, die andere Browser nicht haben.

Cookies waren aktiviert, soweit ich mich erinner, aber das kann ich ja auch noch mal testen.
Guestuser
 
Avatar
 
Betreff:

Re: DiBa & Linux: Wie klappt's?

 · 
Gepostet: 07.01.2003 - 17:35 Uhr  ·  #5
Zitat geschrieben von Karsten Radatz
Ich denke also mal, dass es prinzipiell funktionieren würde.
Bei der SuSE 8.1 Standardinstallation ist für DSL allerdings die MRU/MTU nicht richtig gesetzt. Dazu einmal in /etc/ppp/peers/pppoe und t-dsl die Werte MTU und MRU=1492 eintragen. Eventuell auch noch in /etc/ppp/options (bin ich mir aber nicht sicher, da ich es dort auch nicht stehen habe)

Bevor ich das alles eingetragen hatte, gingen einige SSL verschlüsselte Seiten nicht. Der Browser lädt eine lange Weile und danach kommt ne Fehlermeldung.

Tja ich habe da ein 56k-Modem an der Kiste und verzichte auf Dienstleistungen der DTAG. Da es bei mir keinen anderen DSL-Anbieter gibt muss ich halt erstmal so zurechtkommen, aber für die Freiheit ohne DTAG leben zu dürfen ist es mir das schon wert :)

Trotzdem Danke für den Hinweis mit den MRU/MTU-Problemen bei SuSE. Das Problem ist AFAIK inzwischen auch bei denen in der SDB gelistet
Guestuser
 
Avatar
 
Betreff:

Re: DiBa & Linux: Wie klappt's?

 · 
Gepostet: 07.01.2003 - 20:50 Uhr  ·  #6
Zitat
Tja ich habe da ein 56k-Modem an der Kiste und verzichte auf Dienstleistungen der DTAG.


Soweit ich weiss gibt es nur bei DSL diese Probleme, wegen des DSL Headers von 8 byte...bei einem 56K Modem dürfte es nicht daran liegen.
Ich teste mal ein bischen an meinem Linux Rechner und gebe dann Bescheid wenn ich was rausgefunden habe.
Guestuser
 
Avatar
 
Betreff:

Re: DiBa & Linux: Wie klappt's?

 · 
Gepostet: 11.01.2003 - 17:37 Uhr  ·  #7
Also ich habs nun nochmal an einem anderen Linux Rechner probiert (166Mhz, 64Mb Ram, SuSE 8.1)

Da hat es genau so geklappt wie bei mir zuhause. Als Kennung musste ich allerdings wieder IE 5.01 on Windows 2000 angeben.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 8
Dabei seit: 05 / 2017
Betreff:

Re: DiBa & Linux: Wie klappt's?

 · 
Gepostet: 16.05.2017 - 13:57 Uhr  ·  #8
Also bei meinem Linux hat es gut geklappt
Gewählte Zitate für Mehrfachzitierung:   0